I’ve only made one system change to my phone today, allowing the Magisk app to update to v27.0 — and now my WiFi returns “IP configuration failure” to all networks.

Maybe I’m seeing a correlation where there isn’t one, but I’m curious if others have similar experiences and — more to the point — have any suggestions for fixes.

  • Atemu
    link
    fedilink
    English
    22 months ago

    Well, roll back Magisk and see whether that fixes it.

    • HandlesOP
      link
      English
      22 months ago

      I can’t seem to find the “roll back” option in the app menu :p Sorry, couldn’t help it!

      Correct me if im wrong: I’m on Lineage OS without TWRP, so the only way of downgrading would be flashing the previous version via ADB, right?

      • Atemu
        link
        fedilink
        English
        42 months ago

        I’ve never flashed Magisk through other ways than the recovery.

        With the official recovery, you have to use adb sideload and point it at the APK. It’s actually also an installable zip.

        • HandlesOP
          link
          English
          22 months ago

          Excellent, will give it a shot 👍

      • Refurbished Refurbisher
        link
        fedilink
        English
        12 months ago

        Easiest way would be to uninstall the Magisk app and install 26.4, then go into the app and do a direct install.

        • HandlesOP
          link
          English
          22 months ago

          Doesn’t work; it insists on updating to 27 on opening the older version?

            • HandlesOP
              link
              English
              22 months ago

              Then it just asks for network access to perform the install, still refuses to open…